Disturbance on Paygate

Incident Report for Nexi Paygate

Update

We are continuing to investigate this issue.
Posted Apr 01, 2026 - 08:28 CEST

Investigating

Our monitoring systems are indicating increased processing times for your payment transactions.
Posted Mar 31, 2026 - 14:13 CEST
This incident affects: Checkout and Processing and Portal.