Paygate Disruption - All Services

Incident Report for Nexi Paygate

Resolved

This incident has been resolved.
Posted Mar 31, 2026 - 18:18 CEST

Identified

We have identified the issue and continue working on mitigation
Posted Mar 30, 2026 - 15:29 CEST

Investigating

We are currently investigating this issue.
Posted Mar 30, 2026 - 13:25 CEST
This incident affected: Checkout and Processing and Portal.