Issues with phone system

Incident Report for Nexi Paygate

Resolved

This incident has been resolved.
Posted Mar 31, 2026 - 15:44 CEST

Investigating

Our customer support phone lines are temporarily unavailable. We are actively investigating the issue.

https://payments.nets.eu/contact-support
Posted Mar 31, 2026 - 10:00 CEST
This incident affected: Other.