Disturbance on Nets Easy

Incident Report for Nexi Paygate

Resolved

This incident has been resolved.
Posted Jan 30, 2026 - 12:04 CET

Investigating

We are investigating an issue that affects Nets Easy

This is an automated message
Posted Jan 30, 2026 - 12:01 CET